В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PetryxaMakvin
PetryxaMakvin
21.04.2022 22:59 •  Информатика

Паскаль Написать программу, которая вычисляет Стоимость оплаты за электроэнергию за
текущий месяц. Известно, что СТОИМОСТЬ начисляется по схеме:

До 100 кВт - 90 коп. за кВт;

От 100 кВт до 500 кВт - 168 коп. за кВт;

Более 500 кВт - 224 коп. за кВт;

Количество кВт использованной ЭНЕРГИИ вводиться с клавиатуры.

Выполнить защиту от неправильного ввода данных

Записать конечной результат в файл

Ответ:
alinika2007
alinika2007
04.01.2021 12:32

begin

 var N,B:real;

 write('Введите количество кВт: '); readln(N);

 if N<0 then write('Некорректный ввод: значение должно быть положительным') else

   begin

     case N.Round of

       0..99:B:=N*0.96;

       100..500:B:=N*1.68;

       else B:=N*2.24;

     end;

     append(output,'output.txt');

     write(output,'Использовано энергии '+N+' кВт на сумму '+B+' рублей');

   end;

end.

Примечание:

Программа может выдать ошибку при попытке подключения к файлу output.txt в коренной папке Паскаля. В таком случае нужно создать другой файл, и поместить его в ту же папку, после чего заменить имя 'output.txt' на имя нового файла в процедурах append и write.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?