В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
grasstv
grasstv
23.06.2021 18:01 •  Информатика

ЗАДАЧА C++ Напишите программу, которая считывает число x, а затем пишет его, поставив перед ним х пробелов
Формат входных данных
Целое не отрицательное число x (Гарантируется, что x не меньше нуля и не больше 9)
Формат выходных данных
Число x, перед которым стоит x пробелов.

Ответ:
GEORGYBAZAEV
GEORGYBAZAEV
04.01.2021 00:56

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   for (int i = 0; i < x; i++) cout << " ";

   cout << x;

}

Объяснение:

0,0(0 оценок)
Ответ:
сидоровнекит
сидоровнекит
04.01.2021 00:56

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE,"Russian");

int x;

cin >>x;

if(x>0 && x<9)

{

for(int i= 0; i<x; i++)

{

cout << " ";

}

cout<<x;

}

else cout<<"Число х не соответсвует диапазону";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?