В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksushadream1
ksushadream1
23.07.2021 12:22 •  Информатика

составить программу по информатике. Дано предложение. Вычислить сколько в нем разных(неповторяющихся) знаков препинания.

Ответ:
Selch
Selch
03.01.2021 11:59

Пример решения задачи на языке PascalABC:

var

 J:Array of Char:=('.','!','?',',',';',':','-','(',')','"');

 T:=0;

begin

 var s:string; readln(s);

 var N:=S.ToCharArray;

 for var l:=1 to J.High do

   if N.FindAll(x->(x = J[l]) = true).Length <> 0 then inc(T);

 write('В предложении ',(T<>0)? T.ToString:'не содержится',' уникальных знаков препинания');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?