В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программы,выполняющие данные . для всех числовых типов данных использовать целочисленный тип. 1.написать программу, которая считает количество секунд в часе.пользователь вводит количество часов, а программа в ответ выводит сколько это секунд. 2.написать программу, которая считает угловой коэффициент прямой, проходящей через точки а и в. пользователь вводит последовательно координаты точек, а программа выводит угловой коэффициент по формуле k=ув-уа/хв-ха. 3.написать программу, которая генерирует случайное трёхзначное число и выводит само число, сумму цифр ,произведение цифр.

Ответ:
xastek
xastek
12.06.2020 17:48
1.                                                        

program raf105;

var hour,sec: integer;

begin

write('Введите количество часов: ');

readln(hour);

sec:= hour*60*60;

writeln('Это ',sec,' сек.');

end.

2.                                                        

program raf105;

var Xa,Ya,Xb,Yb,k: real;

begin

write('Введите координаты первой точки (Х и Y): ');

readln(Xa,Ya);

write('Введите координаты второй точки (Х и Y): ');

readln(Xb,Yb);

k:= (Yb-Ya/Xb-Xa);

writeln('Угловой коэффициент: ',k:0:2);

end.

3.                                                        

program raf105;

var abc,a,b,c,sum,pro: integer;

begin

abc:= random(100,999);

a:= abc div 100;

b:= (abc div 10) mod 10;

c:= abc mod 10;

sum:= a+b+c;

pro:= a*b*c;

writeln('Число ',abc);

writeln('Сумма цифр: ',sum);

writeln('Произведение цифр: ',pro);

end.

                                                         PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?