В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Язык Python. Напишите программу, которая будет выводить, какую по счёту дощечку прибили.

Формат ввода
Сначала вводится число – сколько нужно дощечек.
Затем вводятся строки, пока не будет введена строка КОНЕЦ

Формат вывода
Строки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:
Прибили {номер} дощечку.

Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:
ГОТОВО

Если не хватило, то вывести в конце:
МАЛОВАТО​

Ответ:
kotodrotin
kotodrotin
02.01.2021 18:53

x = int(input())

s = ''

c = 0

while s != 'КОНЕЦ':

   s = input()

   if 'доска' in s or 'дощечка' in s:

       c += 1

       print('Прибили', c, 'дощечку.')

   if c == x:

       break

if c != x:

   print('МАЛОВАТО')

else:

   print('ГОТОВО')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?