В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lenapakhomowa
lenapakhomowa
06.04.2023 23:30 •  Информатика

Питон
.напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора(целое количество минут)— 3 День недели(1-понедельник,...7-воскресенье)--5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб.Питон,программа должна быт большая​

Ответ:
DARKxSHADOWxYT
DARKxSHADOWxYT
31.12.2020 19:30

ответ:Язык Python в виде ф-ии

def phoneCoubt(iMin, iDay):

 tax = 1.84

 rez = tax*iMin

 if iDay > 5: rez *= 0.8

 return rez

Объяснение:

0,0(0 оценок)
Ответ:
13angelob
13angelob
31.12.2020 19:30

minutes = int(input('Введите количество минут: '))

day = int(input('Введите день недели (1 - понедельник ... 7 - воскресенье): '))

discount = int(input('Введите размер скидки (число): '))

price = float(input('Введите цену за 1 минуту: '))

if (day == 6 or day == 7):

 print("%.3f" % float((minutes * price) - (minutes * price / 100 * discount)))

else:

 print("%.3f" % float(minutes * price))

Объяснение:

minutes = int(input('Введите количество минут: '))  # Вводим количество минут с клавиатуры

day = int(input('Введите день недели (1 - понедельник ... 7 - воскресенье): '))  # Вводим номер дня недели с клавиатуры

discount = int(input('Введите размер скидки (число): '))  # Вводим размер скидки с клавиатуры

price = float(input('Введите цену за 1 минуту: '))  # Вводим цену за 1 минуту разговора с клавиатуры

if (day == 6 or day == 7):  # Если суббота или воскресенье

 print("%.3f" % float((minutes * price) - (minutes * price / 100 * discount)))  # Выводим цену с учетом скидки (( после запятой 3 знака ))

else:  # Иначе

 print("%.3f" % float(minutes * price)) # Выводим без учета скидки (( после запятой 3 знака ))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?