В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mintbouquet
mintbouquet
15.02.2021 07:56 •  Информатика

1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции:
1-квадрат; 2-корень квадратный; 3-синус; 4-косинус
и считает соответствующую функцию для введённого с клавиатуры числа.

Ответ:
neli2017
neli2017
29.12.2020 22:38

#include <iostream>

#include <cmath>

#include <conio.h>

using namespace std;

int main() {

   cout << "Введите номер необходимой функции:\n1-квадрат; 2-корень квадратный; 3-синус; 4-косинус\n";

   char c;

   cin >> c;

   // Если используешь обычный компилятор (не онлайн), можно написать "char c = _getch()";

   

   cout << "Введите число: \n";

   int num;

   cin >> num;

   

   switch(c) {

       case '1':

           cout << pow(num ,2);

           break;

       case '2':

           cout << sqrt(num);

           break;

       case '3':

           cout << sin(num);

           break;

       case '4':

           cout << cos(num);

           break;

       default:

           cout << "Ошибка ввода";

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?