В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ариана54091
ариана54091
11.09.2021 04:24 •  Информатика

Задача: Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля и увеличивающую его на 4, если число больше либо равно нулю . В ПАСКАЛЕ

Ответ:
gptisveto
gptisveto
28.12.2020 19:38

begin

 var N := readinteger;

 if (N < 0) then

   N := 0

 else

   inc(N, 4);

 write(N);

end.

Объяснение:

begin  // Начало программы

 var N := readinteger;  // Считываем значение переменной N с клавиатуры

 if (N < 0) then  // Если значение переменной N < 0, тогда

   N := 0  // Значение переменной N = 0

 else  // Иначе

   inc(N, 4);  // Увеличиваем значение переменной N на 4

 write(N);  // Выводим значение переменной N

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?