В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ILYA3421
ILYA3421
15.08.2021 18:44 •  Информатика

Здравствуйте с информатикой. Надо написать программу в Паскале. Задача:
Вычислить значение функции. Осуществить вывод значений исходных данных и результат вычисления значений функции, сопровождая вывод наименованиями переменных.
Кто разбирается


Здравствуйте с информатикой. Надо написать программу в Паскале. Задача: Вычислить значение функции.

Ответ:
ник3123
ник3123
28.12.2020 09:52

program z1;

var a,b,x,y:real;

begin

a:=2.6;

b:=-0.39;

x:=0.8;

while x<=2 do

begin

if x<2.8 then y:=(a+b)/(exp(x) + cos(x))

else if x>=6 then y:=exp(x) + sin(x)

else y:=(a+b)/(x+1);

writeln('x = ',x,'     y = ',y:0:3);

x:=x+0.5

end

end.

Объяснение:

Заданы значения a, b и x

Цикл с предусловием (пока x<=2), выполняем действия:

1) проверяем условие по какой формуле следует считать y и считаем его

2) выводим на экран текущие значения x и y

3) увеличиваем x на шаг

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?