В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pomarinka1111
pomarinka1111
17.03.2020 19:08 •  Информатика

Напишите программу, которая узнаёт у человека его возраст и сообщает, кто он: малыш (до 6 лет), школьник (от 7 до 17 лет), взрослый (от 18 до 64 лет), аксакал (от 65 до 120 лет) или привидение (всё остальное).

Формат входных данных
Вводится целое число N (0≤N≤231−1).

Формат выходных данных
Требуется вывести «BABY», «SCHOOLCHILD», «ADULT», «ELDER» или «GHOST» соответственно для малыша, школьника, взрослого, аксакала или привидения.

входные данные выходные данные
3 BABY
21 ADULT

Ответ:
And2008
And2008
27.12.2020 16:35

import java.util.Scanner;

public class OldYears {

public static void main(String[] args) {

int years = readConsole("Enter age of the person", 0, 231 - 1);

System.out.printf("Enter value: %s;%sAnswer: %s;", years, System.lineSeparator(), getResult(years));

}

public static int readConsole(String answer, int startRange, int endRange) {

Scanner read = new Scanner(System.in);

boolean value = false;

int result = 0;

while (!value) {

System.out.printf("%s: ", answer);

try {

result = Integer.valueOf(read.next());

if (!(value = result >= startRange && result <= endRange)) {

System.out.printf("Incorrect value [%s <= value <= %s]. Try again.%s", startRange, endRange, System.lineSeparator());

}

} catch (NumberFormatException e) {

System.out.println("The value is not number. Try again.");

}

}

return result;

}

public static String getResult(int years) {

String result;

if (years >= 0 && years <= 6) {

result = "BABY";

} else if (years > 6 && years <= 17) {

result = "SCHOOLCHILD";

} else if (years > 17 && years <= 64) {

result = "ADULT";

} else if (years > 64 && years <= 120) {

result = "ELDER";

} else {

result = "GHOST";

}

return result;

}

}

Объяснение:

0,0(0 оценок)
Ответ:
LimomPas
LimomPas
27.12.2020 16:35

#include <iostream>

using namespace std;

int main()

{

   int age;

   cout << "Введите свой возраст: ";

   cin >> age;

   if (age <= 6)

   {

       cout << "BABY";

   }

   else if (age <= 17 && age >= 7)

   {

       cout << "SCHOOLCHILD";

   }

   else if (age <= 64 && age >= 18)

   {

       cout << "ADULT";

   }

   else if (age <= 120 && age >= 65)

   {

       cout << "ELDER";

   }

   else

   {

       cout << "GHOST";

   }

}

Объяснение:

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int age; // Переменная, хранящая возраст

   cout << "Введите свой возраст: "; // Вывод сообщения в консоль

   cin >> age; // Вводим возраст с клавиатуры

   if (age <= 6) // Если значение переменной age ≤ 6

   {

       cout << "BABY"; // Выводим BABY

   }

   else if (age <= 17 && age >= 7) // Если значение переменной age ≤ 17 И ≥ 7

   {

       cout << "SCHOOLCHILD"; // Выводим SCHOOLCHILD

   }

   else if (age <= 64 && age >= 18) // Если значение переменной age ≤ 64 И ≥ 18

   {

       cout << "ADULT"; // Выводим ADULT

   }

   else if (age <= 120 && age >= 65) // Если значение переменной age ≤ 120 И ≥ 65

   {

       cout << "ELDER"; // Выводим ELDER

   }

   else // Иначе

   {

       cout << "GHOST"; // Выводим GHOST

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?