В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
horki1
horki1
22.12.2020 03:59 •  Информатика

Составить программу, , нужно ! пятиугольник abcde задан координатами своих вершин (x1,y1)(x2,y2)(x3,y3)(x4,y4)(x5,y5) соответственно. найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

Ответ:
gela06
gela06
12.06.2020 09:46

#include <iostream>

using namespace std;

 

struct my{

   int x;

   int y;

}

 

void S_size() ;

 

int main()

{
   my my_struct = new my[5];

   for(int i =0 ;i<5;i++)

{

  cin >> my_struct[i].x;

  cin >> my_struct[i].y;

 

S_size();

}

 

S_size()

{

  double S = 0.5*((my_struct[0].x*my_struct[1].y)-(my_struct[1].x *my_struct[0].y))*((my_struct[1].x * my_struct[2].y)-(my_struct[2].x*my_struct[1].y))*((my_struct[2].x * my_struct[3].y)-(my_struct[3].x*my_struct[2].y))*((my_struct[3].x * my_struct[4].y)- (my_struct[4].x*my_struct[3].y));

cout << S ;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?