В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Uprava
Uprava
25.09.2022 06:10 •  Информатика

Составьте программу нахождения в линейном массиве целых чисел из 10 элементов, заполненных случайным образом, произведение нечетных элементов.

Ответ:
prostosadkotik
prostosadkotik
25.12.2020 13:27

program z1;

var a:array[1..10] of integer;

i,p:integer;

begin

p:=1;

randomize;

writeln('Массив: ');

for i:=1 to 10 do

begin

a[i]:=random(10);

write (a[i]:3);

if a[i] mod 2 <> 0 then p:=p*a[i]

end;

writeln;

write ('p = ',p)

end.

Объяснение:

р = 1, т.к. при умножении на 1 произведение не изменяется

Заполняем массив используя random

Выводим элемент

Если элемент нечётный, то считаем произведение

Вывод произведения

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?