В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
llovich
llovich
13.07.2021 10:20 •  Информатика

Написать программу, результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) делать в turbo pascal

Ответ:
вирона1
вирона1
12.06.2020 08:58

function sum (n : integer) : integer;

begin

  sum := 0;

  while n > 0 do

  begin

    sum := sum + n mod 10;

    n := n div 10;

  end;

end;

 

var

  a : integer;

begin

  repeat

    writeln ('a = ');

    read (a);

  until sum (a) = 10;

  writeln ('OK');

end.

0,0(0 оценок)
Ответ:
ушкаа
ушкаа
12.06.2020 08:58

var
a,a1,a2:integer;
begin
repeat
writeln (' Введите число');
readln (a);
a1:=a div 10;
a2:=a mod 10;
until (a1+a2=10);
writeln ('Верно ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?