В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nicishcina
nicishcina
01.10.2022 15:17 •  Информатика

Дан одномерный массив Y, состоящий из 15 элементов. Подсчитать сумму и произведение элементов массива, меньших 30. Написать программу решения задачи на языке программирования здесь

Ответ:
irinavardanyan
irinavardanyan
24.12.2020 18:46

var a: array [1..15] of integer;

i, n, s, p: integer;

begin

s:=0;

p:=1;

Read(n);

For i:= 1 to n do

Read(a[i]);

For i:=1 to n do

if a[n]<30 then begin

s:=s+a[i];

p:=p*a[i];

end;

Write(s, ' ', p);

end.

0,0(0 оценок)
Ответ:
iiiin
iiiin
24.12.2020 18:46

s,pr = 0,1

Y = []

for i in range(30):

   Y.append(int(input()))

for i in range(30):

   if Y[i] < 30:

       s += Y[i]

       pr *= Y[i]

print(s,pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?