В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
МОМОГИТИ1
МОМОГИТИ1
20.02.2020 20:50 •  Информатика

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль)

Ответ:
Лиза505090
Лиза505090
30.09.2020 21:47

var

a,b,c:integer;

writeln('a,b,c'); readln(a,b,c);

if (a>b) and (a>c) then writeln(a);

if (b>a) and (b>c) then writeln(b);

if (c>b) and (c>a) then writeln(c);

end;

можно через один if.

 

0,0(0 оценок)
Ответ:
lele4
lele4
30.09.2020 21:47

var

  a, b, c, m : integer;

begin

  read (a, b, c);

  m := a;

  if b > m then m := b;

  if c > m then m := c;

  writeln (m);

end.

 

ps так корректнее, потому что в первом ответе не учтено равенство чисел.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?