В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Pussyellien
Pussyellien
28.03.2021 18:47 •  Информатика

Написать программу которая про суммирует все 2ух значные числа содержащие 1

Ответ:
bogdan2041
bogdan2041
12.06.2020 06:55

var a,a1,a2,sum,n,i:integer;

begin

readln (n);

for i:=1 to n do

begin

readln (a);

a1:=a div 10;

a2:=a mod 10;

if (a1=1) or (a2=1) then sum:=sum+a;

end;

writeln (sum);

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?