В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Farzalievik
Farzalievik
24.02.2020 09:58 •  Информатика

1) Написать программу на языке Паскаль вычисления выражения:

S = 4f^2-√25+12m

№2 Написать программу на языке Паскаль вычисления выражения. В ответе должно быть не только число, но и подпись кто выполнил.

V = (2z^2-13)/(5h-10)+|n-25|

Ответ:
karpova79
karpova79
22.12.2020 21:58

1)

begin

 var (f, m) := readinteger2;

 var s := 4 * sqr(f) - sqrt(25) + 12 * m;

 write(s);

end.

2)

begin

 var (z, h, n) := readinteger3;

 var v := (2 * sqr(z) - 13) / (5 * h - 10) + abs(n - 25);

 write(v);

 writeln('Выполнил: ВАШЕ ФИО');

end.

Объяснение:

sqr(x) - возводит число х в квадрат;

sqrt(x) - вычисляет квадратный корень из числа x;

abs(x) - вычисляет модуль числа х.

1)

begin  // Начало программы

 var (f, m) := readinteger2;  // Считываем с клавиатуры значения f и m

 var s := 4 * sqr(f) - sqrt(25) + 12 * m;  // Вычисляем выражение

 write(s);  // Выводим ответ

end. // Конец программы

2)

begin  // Начало программы

 var (z, h, n) := readinteger3;  // Считываем с клавиатуры значения z, h и n.

 var v := (2 * sqr(z) - 13) / (5 * h - 10) + abs(n - 25);  // Вычисляем выражение

 write(v);  // Выводим ответ

 writeln('Выполнил: ВАШЕ ФИО'); // Здесь вводите свое ФИО

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?