В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NeYch999
NeYch999
14.06.2020 02:02 •  Информатика

Дан массив 10 целых чисел, в диапазоне от 1 до 30. Найти произведение элементов массива, кратных написать программу!

Ответ:
AnonimStudent228
AnonimStudent228
12.02.2021 18:30

ответ

begin

 ReadArrInteger(10).Where( x -> x mod 5 = 0).Product().Print();

end.

PascalABC.NET

0,0(0 оценок)
Ответ:
Riek
Riek
12.02.2021 18:30

begin

 var mas := ArrRandomInteger(10, 1, 30);

 mas.Println;

 var composition := 1;

 for var i := 0 to mas.Length - 1 do

 begin

   if (mas[i] mod 5 = 0) then

   begin

     composition := composition * mas[i];

   end;

 end;

 write(composition);

end.

Объяснение:

begin  // Начало программы

 var mas := ArrRandomInteger(10, 1, 30);  // Объявление массива размером 10 + заполнение массива случайными значениями из диапазона [1, 30].

 mas.Println;  // Вывод массива

 var composition := 1;  // Переменная, хранящая произведение чисел, которые делятся на 5 без остатка

 for var i := 0 to mas.Length - 1 do  // Идём от нуля до размера массива - 1

 begin  // Начало цикла

   if (mas[i] mod 5 = 0) then  // Если значение массива с индексом i делится на 5 без остатка

   begin  // Начало условного оператора

     composition := composition * mas[i];  // Умножаем произведение на значение массива

   end;  // Конец условного оператора

 end;  // Конец цикла

 write(composition);  // Выводим ответ

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?