В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Fastikqq
Fastikqq
10.03.2022 16:32 •  Информатика

Написать программу(паскаль). с пояснениями, желательно. нужно с for. найти сумму всех n-значных чисел, кратных k.(1 < (или равно) n< (или равно)4).

Ответ:
Vip6longin
Vip6longin
30.09.2020 21:15

program sada;

var k,n,res,i:integer;

     temp:string;

begin

res:=0;

readln(k);

temp:='';

for i:=1 to n do

temp:=temp+'9';

n:=strtoint(temp);

for i:=1 to n do begin

if (i mod k = 0) then res:=res+i;

end;

writeln(res);

end.

 

 

p.s. Программа написана на pascalABC

0,0(0 оценок)
Ответ:
АнькаЦитрус
АнькаЦитрус
30.09.2020 21:15

var

  k, n, Summ, i, max, min:integer;

begin

  write('n = '); readln(n);

  write('k = '); readln(k);

  max := 9;

  min := 1;

  for i := 2 to n do

  begin

    max := max * 10 + 9;

    min := min * 10;

  end;

  for i := min to max do

    if i mod k = 0 then

      Summ := Summ + i;

  writeln('Сумма = ', Summ);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?