В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Милки1319
Милки1319
02.04.2022 03:37 •  Информатика

Напишите программу, которая находит произведение двух наибольших чисел из последовательности натуральных чисел. программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. значения чисел не превышают 30000. программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наибольшие

Ответ:
shavkatbronduk1
shavkatbronduk1
30.09.2020 21:16

var temp,max,max2:integer;

begin

   readln(temp);

   max:=0;

   max2:=0;

   while (temp<>0) do begin

      if(temp>max) then begin max2:=max; max:=temp; end

         else if(temp>max2) then max2:=temp;

      readln(temp);

   end;

   writeln(max*max2)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?