В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kalimovnadir
Kalimovnadir
18.05.2023 10:14 •  Информатика

Составить программу,которая определяет сколько раз встречается в таблице а максимальное по величине число.pascal.массивы. заранее : )

Ответ:
RinaZum
RinaZum
12.06.2020 01:27

const n=100;

m=100;

var A: array[1..n,1..m] of integer;

i,j,maxi,maxj,k: integer;

begin

randomize;

for i := 1 to n do begin

    for j := 1 to m do begin

        A[i,j] := random(100);

    end;

end;

maxi := 1;

maxj := 1;

for i := 1 to n do begin

    for j := 1 to m do begin

        if (A[i,j] > A[maxi,maxj]) then begin

            maxi := i;

            maxj := j;

        end;

    end;

end;

k := 0;

for i := 1 to n do begin

    for j := 1 to m do begin

        if (A[i,j] == A[maxi,maxj]) then k := k + 1;

    end;

end;

writeln('k = ', k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?