В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maksik1324
maksik1324
01.01.2023 18:58 •  Информатика

написать программу для С++ Дан массив из n элементов. Найти сумму элементов, стоящих на нечетных
местах и вывести их на экран. Затем вставить их в новый массив умножив на
n, и удалить последний элемент.​

Ответ:
kotovich9292
kotovich9292
17.12.2020 08:18

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

using namespace std;

int main() {

vector<int> arr;

int n;

cout << "n: ";

cin >> n;

srand(time(0));

long long sum = 0;

vector<long int> multi;

for(int i = 0; i<10; ++i) { //  тут поменять чтобы изменить колво чисел

arr.push_back(rand());

if(i%2!=0) {

sum+=arr[arr.size()-1];

cout << arr[i] << " ";

multi.push_back(arr[arr.size()-1]*n);

}

}

cout << endl << "Multi: ";

for(int i = 0; i<multi.size(); ++i) {

cout << multi[i] << " ";

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?