В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
гот12
гот12
08.12.2020 02:43 •  Информатика

1) написать программу, которая определяет номера строк двумерного массива a[1..6,1..4], в которых содержится хотя бы один нулевой элемент. 2) 5. составить программу заполнения массива b[1..10] таким образом: элементы с нечетными индексами равны числу 2, а элементы с четными индексами равны числу 5.

Ответ:
taya99191
taya99191
30.09.2020 20:58

1)

var A: array [1..6,1..4] of integer;

i,j: integer;

begin

randomize;

for i := 1 to 6 do begin

    for j := 1 to 4 do begin

        A[i,j] := random(20) - 10;

    end;

end;

 

for i := 1 to 6 do begin

    for j := 1 to 4 do begin

        if (A[i,j] == 0) then begin

            writeln("0 v stroke ", i);

            continue;

        end;

    end;

end;

 

end.

 

2)

var B: array [1..10] of integer;

i: integer;

begin

for i := 1 to 10 do begin

    if (i mod 2 == 0) then B[i] := 5;

    else B[i] := 2;

end;

 

for i := 1 to 10 do begin

    writeln(B[i]);

end;

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?