В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maximfz
maximfz
01.01.2022 03:37 •  Информатика

50 .напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 13. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 13. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число - минимальное число, кратное 13. входные данные 3, 130, 25, 169. выходные данные 130. (чтобы её можно было запустить в паскаль) ​

Ответ:
mischkulentsov
mischkulentsov
11.06.2020 22:54

Var i,c,count,min:integer;

Begin

Read (count);

Min:=30000;

For i:=1 to count do

Begin

Read(c);

If c < min and c mod 13 = 0 then

Min:= c;

End;

Write(min);

End.

0,0(0 оценок)
Ответ:
оксана754
оксана754
11.06.2020 22:54

#include <iostream>

using namespace std;

int main()

{

   int b,c,d,e,f,g;

   cin >>b;

   d=30001;

   int A[b];

   for ( int i=0;b>i;i++ )

   {

       cin >> A[i];

   }

       for ( int i=0;b>i;i++ )

   {

       if ( A[i]%13 ==0 )

       {

           if ( A[i]< d )

           {

               d=A[i];

           }

       }

   }

   cout << d;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?