В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daniilmosl
daniilmosl
19.09.2022 10:18 •  Информатика

Составьте программу нахождения наибольшего значения роста у двух членов школьной баскетбольной команды (рост спортсменов вводится с клавиатуры).

Ответ:
АйкоУесМ
АйкоУесМ
30.09.2020 20:53

Uses
  Crt;
Var
  i, N, kol: byte;
  sum_rost, sr_rost: real;
  team: array[1..100] of real;
Begin
  sum_rost := 0.0;
  sr_rost := 0.0;
  kol := 0;
  write('Введите количество членов команды');
  read(N);
  writeln('Введите рост каждого члена команды');
  for i := 1 to N do
    begin
      readln(team[i]);
      sum_rost := sum_rost + team[i];
    end;
  sr_rost := sum_rost / N;
  for i := 1 to N do
    if (team[i] > sr_rost) then
      kol := kol + 1;
  writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
  write(' равно ', kol);
End.

Я надеюсь надо было на паскале написать?)

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?