В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Neekeetos
Neekeetos
14.04.2020 01:32 •  Информатика

1 Задан целочисленный одномерный массив а состоящий из n элементов. Написать программу подсчета количества, суммы и произведения отрицательных элементов массива. 2 Перенести условие задачи 1 на использование двумерного массива а, размерности 3×3.

Ответ:
corvet42
corvet42
14.12.2020 12:54

1.

#include <iostream>

#define N 10

int main()

{

using namespace std;

int count = 0, sum = 0, mult = 1;

int arr[N]{0, 7, 5, 2, -10, -3, 4, 6, 12, -1};

for (const auto i : arr)

{

 if (i < 0)

 {

  count++;

  sum += i;

  mult *= i;

 }

}

cout << "Count = " << count << "\nSum = " << sum

<< "\nMult = " << mult;

return 0;

}

2.

#include <iostream>

#define N 3

int main()

{

using namespace std;

int count = 0, sum = 0, mult = 1;

int arr[N][N]{0, 7, 5, 2, -10, -3, 4, 6, -1};

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N; j++)

 {

  if (arr[i][j] < 0)

  {

   count++;

   sum += arr[i][j];

   mult *= arr[i][j];

  }

 }

}

cout << "Count = " << count << "\nSum = " << sum

<< "\nMult = " << mult;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?