В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elinazayka
elinazayka
04.07.2022 03:27 •  Информатика

Написать одну программу для вычисления трех логических переменных: rez1, rez2, rez3. используя следующие данные. Три вычисления в одной программе.Даны значения целочисленных переменных: а = 10, b = 20. Чему будет равно значение логической переменной rez после выполнения операции присваивания? а) rez:=(а=10) or (b>10) б) rez:=(а>5) and (b>5) and (a 20)

Ответ:
илья1947
илья1947
12.12.2020 08:39

program z1;

var a,b: integer;

rez1, rez2, rez3: boolean;

begin

a := 10;

b := 20;

rez1:=(a=10) or (b>10);

rez2:=(a>5) and (b>5) and (a>20);

rez3:=(not(a<15)) or (b>20);

writeln('rez1 = ',rez1,'     rez2 = ',rez2,'     rez3 = ',rez3)

end.

Объяснение:

Объявляем переменные rez1, rez2, rez3 - логическими.

Пишем условия

Выводим на экран

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?