В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pasha4431
pasha4431
24.08.2021 15:46 •  Информатика

1) дан одномерный массив из 12 элементов. составить программу заполняющую массив целыми числами в интервале -20 до 15 2)требуется подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8 3)дан одномерный числовой массив,изменить знак элементов массива к[1; 12] на противоположный

Ответ:
Imychka
Imychka
30.09.2020 20:16

var

  a:array[1..12] of integer;

  i:integer;

begin

  randomize;

  writeln('Сгенерированный массив:');

  for i := 1 to 12 do

  begin

    a[i] := random(36) - 15;

    write(a[i], ' ');

  end;

  writeln;

end.

 

//вторая программа

const

  n = 8;

var

  a:array[1..n] of integer;

  i, count3, count4, count5:integer;

begin

  randomize;

  writeln('Оценки учеников:');

  for i := 1 to n do

  begin

    a[i] := random(3) + 3;

    write(a[i], ' ');

    if a[i] = 5 then

      inc(count5);

    if a[i] = 4 then

     inc(count4);

    if a[i] = 3 then

      inc(count3);

  end;

  writeln;

  writeln('Троек - ', count3);

  writeln('Четверок - ', count4);

  writeln('Пятерок - ', count5);

end.

 

 

 

 

//третья программа

var

  k:array[1..12] of integer;

  i:integer;

begin

  randomize;

  writeln('Сгенерированный массив:');

  for i := 1 to 12 do

  begin

    k[i] := random(36) - 15;

    write(k[i], ' ');

  end;

  writeln;

  writeln('Преобразованный массив:');

  for i := 1 to 12 do

  begin

    k[i] := k[i] * (-1);

    write(k[i], ' ');

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?