В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан целочисленный массив из 7 элементов, в котором записаны значения температуры воздуха за неделю. Элементы массива могут принимать значения от (–10) до 0. Составьте программу, которая подсчитывает и выводит номер дня недели, когда температура была максимальной.

Ответ:
aodushkina824oya9o5
aodushkina824oya9o5
09.12.2020 18:43

var

 temp:array [1..7] of shortint;

 i,max:byte;

begin

 randomize;

 for i:=1 to 7 do temp[i]:=random(10)-10;

 max:=1;

 for i:=2 to 7 do if temp[i]>temp[max] then max:=i;

 writeln(max);

end.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?