В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lizik741Limon
Lizik741Limon
15.11.2020 06:36 •  Информатика

Составить программу в c++ дополнительного задания 2 . Фотка прикреплена заранее.


Составить программу в c++ дополнительного задания 2 . Фотка прикреплена заранее.

Ответ:
юра417
юра417
07.12.2020 20:37

#include <iostream>

using namespace std;

double y(double a, double b, double c, double x) {

   if (c == x && b + c + x != 0)

       return ((a + b) * (a + c) * (a + x)) / (b + c + x);

   if (c != x && 1 + b != 0 && 1 + a != 0 && a / (1 + b) + b / (1 + a) >= 0)

       return sqrt(a / (1 + b) + b / (1 + a));

   return -1e9 - 7;

}

signed main() {

   double a, b, c, x, ans;

   cin >> a >> b >> c >> x;

   ans = y(a, b, c, x);

   ans == -1e9 - 7 ? cout << "No solution" : cout << ans;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?