В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dasulya21
Dasulya21
06.02.2023 16:03 •  Информатика

Написать программу на pascal - в одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. массив заполняется случайным образом числами от 0 до 50.

Ответ:
goldwildcat1
goldwildcat1
11.06.2020 16:54

const

  n = 20;

var

  a:array[1..n] of integer;

  i, k:integer;

begin

  randomize;

  writeln('Исходный массив: ');

  for i := 1 to n do

  begin

    a[i] := random(51);

    write(a[i], ' ');

  end; 

  writeln;

  

  write('k = '); readln(k);

  if (k > n) or (k  < 1) then

  begin

    writeln('элемента с таким индексом нет');

    readln;

    Exit;

  end;

  for i := k to n - 1 do

    a[i] := a[i + 1];

  a[n] := 0;

  writeln('Измененный массив:');

  for i := 1 to n - 1 do

    write(a[i], ' ');

  readln;

  writeln;

end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?