В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Polina73837739
Polina73837739
05.10.2020 22:25 •  Информатика

Составьте программу для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7 одновременно. с цикла for на паскале

Ответ:
vaierchik
vaierchik
24.05.2020 10:01

Вот программа, написанная на паскале.
Комментарий: sum - общая сумма всех чисел, делящихся на 5 и на 7 одновременно, count - их количество.


ответ: 385


Составьте программу для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7 однов
0,0(0 оценок)
Ответ:
zozoshcka17
zozoshcka17
24.05.2020 10:01

var s: real;

      i,n: integer;

begin

  s:=0;

  n:=0;

  for i:=250 to 500 do begin

    if (i mod 5=0) and (i mod 7=0) then begin s:=s+i; n:=n+1;

                                                         end;

                                end;

  s:=s/n;

  writeln(s);

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?