В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
839010
839010
15.12.2020 08:31 •  Информатика

Составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random); +эта программа должна включать в себя массив ( в писать по возможности с объяснением)

Ответ:
niganai
niganai
11.06.2020 14:37

Var koef:array[1..3] as integer; 

d:real;

i:integer;

Begin

Randomize;

;Генерируем коэффициенты a b c

for i:=1 to 3  do

begin

koef[i]:=random(100);

end;

;Считаем дискриминант 

d:=koef[2]*koef[2]-4*koef[1]*koef[3];

;выводим ответ

Writeln(d:5:2);

end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?