В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Xzxzxzxzxzzxzxz
Xzxzxzxzxzzxzxz
26.11.2020 02:32 •  Информатика

Информатика.паскаль.дано натуральное число n. составить программу, которая определяет, сколько цифр этого числа кратны трем. p.s т.е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.

Ответ:
leryush1
leryush1
11.06.2020 13:57

var

  N, count:integer;

begin

   write('N = ');

  readln(N);

  count := 0;

  while N > 0 do

  begin

    if (N mod 10) mod 3 = 0 then

      count := count + 1;

    N := N div 10;

  end;

  writeln('Count = ', count);

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?