В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Йорик336
Йорик336
22.01.2020 19:53 •  Информатика

Написать программу на С# для решения следующей задачи: в матрице D(10,10) найти
строки с наибольшей и наименьшей суммой элементов и вывести на печать
данные строки и суммы.

Ответ:

Объяснение:

using System;

class Program

{

   static int P(string p)

   {

       int a = 0, dec = 1;

       for (int i = p.Length - 1; i >= 0; i--)

       {

           a += (p[i] - '0') * dec;

           dec *= 10;

       }

       return a;

   }

   static void Main(string[] args)

   {

       int minSum = 1000000000, maxSum = 0, itMin = 0, itMax = 0;

       for (int i = 0; i < 10; i++)

       {

           int nowSum = 0;

           string a = Console.ReadLine();

           string[] now = a.Split(' ');

           for (int j = 0; j < now.Length; j++)

           {

               int n = P(now[j]);

               nowSum += n;

           }

           if (minSum > nowSum)

           {

               itMin = i;

               minSum = nowSum;

           }

           if (maxSum < nowSum)

           {

               itMax = i;

               maxSum = nowSum;

           }

       }

       Console.WriteLine("{0} - строка с минимумом, {1} - строка с максимумом", itMin + 1, itMax + 1);

       Console.ReadLine();

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?