В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
салемы
салемы
17.05.2020 05:33 •  Информатика

Программа паскаль дано трехзначное число. напишите программу, которая определяет: является ли число перевертышем, т.е числом, десятичная запись которого читается одинаково слева направо и справа налево пример входных данных: 122, 121, 222 пример выходных данных: нет, перевертыш, перевертыш

Ответ:
markzastawa
markzastawa
11.06.2020 13:23

var
  c, f, First, count:integer;
begin
  write('c = ');
  readln(c);
  f := c;
  while (f div 10 > 0) do
  begin
    First := f div 10;
    count := 1;
    while (First div 10 > 0) do
    begin
      First := First div 10;
      Inc(count);
    end;
    if First <> f mod 10 then
    begin
      writeln('No');
      readln;
      Exit;
    end;
    
    while count > 0 do
    begin
      First := First * 10;
      dec(count);
    end;
    f := f - First;
    f := f div 10;
  end;
  writeln('Changeling');
  readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?