В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
UdTzgu
UdTzgu
25.06.2022 08:29 •  Информатика

Дан двумерный массив целых чисел. а) Составить программу, определяющую, верно ли, что сумма элементов
строки массива с известным номером оканчивается цифрой 0.
МОЖНО ЧЕРЕЗ С++ И ПОЛНОСТЬЮ КОД, ​

Ответ:
maker1287
maker1287
01.12.2020 15:30

#include <iostream>

using namespace std;

int main()

{

   int line, column;

   cout << "Введите количество строк и столбцов через пробел: ";

   cin >> line >> column;

   int array[50][50] = {};

   cout << "Введите элементы двумерного массива: \n";

   for (int i = 0; i < line; i++ )

   {

       for (int j = 0; j < column; j++)

       {

           cin >> array[i][j];

       }

       cout << endl;

   }

   int amount = 0;

   int line_index;

   cout << "Введите индекс строки массива: ";

   cin >> line_index;

   for (int j = 0; j < column; j++)

   {

       int i = line_index;

       amount += array[i][j];

   }

   if (amount % 10 == 0)

   {

       cout << "YES";

   }

   else

   {

       cout << "NO";

   }

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве

   cout << "Введите количество строк и столбцов через пробел: ";  // Вывод сообщения в консоль

   cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры

   int array[50][50] = {};  // Создание целочисленного массива размером 50х50

   cout << "Введите элементы двумерного массива: \n";  // Вывод сообщения в консоль

   for (int i = 0; i < line; i++ )  // Ввод элементов массива

   {  // Ввод элементов массива

       for (int j = 0; j < column; j++)  // Ввод элементов массива

       {  // Ввод элементов массива

           cin >> array[i][j];  // Ввод элементов массива

       }  // Ввод элементов массива

       cout << endl;  // Ввод элементов массива

   }  // Ввод элементов массива

   int amount = 0;  // Создание целочисленной переменной, хранящей сумму нужной строки

   int line_index;  // Переменная, хранящая индекс нужной строки

   cout << "Введите индекс строки массива: ";  // Вывод сообщения в консоль

   cin >> line_index;  // Ввод индекса нужной строки с клавиатуры

   for (int j = 0; j < column; j++)  // Находим все элементы нужной строки

   {

       int i = line_index;  // Нужна сумма определенной строки ⇒ значение переменной i будет постоянным

       amount += array[i][j];  // Переменная, хранящая сумму элементов нужной строки, суммируется с элементами строки

   }

   if (amount % 10 == 0)  // Если последняя цифра суммы = 0

   {

       cout << "YES";  // Выводим "YES"

   }

   else  // Иначе

   {

       cout << "NO";  // Выводим "NO"

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?