В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilyapleshakov29
ilyapleshakov29
27.09.2021 03:38 •  Информатика

Написать программу для вычисления n-ой степени числа a (an). протестировать программу для а) a=3 и n=4, б) a=2 и n=5.

Ответ:
likaoolika
likaoolika
11.06.2020 12:50

Program zadacha;

var a,n,i:integer;

Begin

read(a,n);

for i:=1 to n do

      a:=a*a;

writeln(a);

end.

 

или как вариант

 

Program zadacha;

var a,n:integer;

Begin

read(a,n);

x:=exp(ln(a)*n);

writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?