В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vladimirmir28
Vladimirmir28
14.04.2023 17:29 •  Информатика

Условие
Требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c.

Формат входных данных
Входной поток содержит три целых числа в одной строке — a, b и c (∣∣a∣∣,∣∣b∣∣,∣∣c∣∣≤5⋅108).

Формат выходных данных
Выведите одно число — искомую сумму.
входные данные
5 -5 1
выходные данные
6

Ответ:
renatadautova
renatadautova
29.11.2020 16:26

#include <iostream>

using namespace std;

int main() {

int x[3];

int s = 0;

for (int i = 0; i < 3; i++) {

 cin >> x[i];

 if (x[i] > 0) {

  s += x[i];

 }

}

cout << s;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?