В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ddfdffdf
ddfdffdf
10.08.2020 10:35 •  Информатика

РЕШИТЬ ЗАДАЧУ НА С++ Требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c.

Формат входных данных
Входной поток содержит три целых числа в одной строке — a, b и c (∣∣a∣∣,∣∣b∣∣,∣∣c∣∣≤5⋅108).

Формат выходных данных
Выведите одно число — искомую сумму.

входные данные
5 -5 1
выходные данные
6

Ответ:
Ксения654654
Ксения654654
29.11.2020 15:55

#include <iostream>

using namespace std;

int main()

{

   int a, b, c;

   int amount = 0;

   cin >> a >> b >> c;

   if (a > 0)

   {

       amount += a;

   }

   if (b > 0)

   {

       amount += b;

   }

   if (c > 0)

   {

       amount += c;

   }

   cout << amount;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a, b, c;  // Создание целочисленных переменных a, b, c

   int amount = 0;  // Создание целочисленной переменной amount, которая будет хранить сумму положительных чисел. Значение переменной = 0

   cin >> a >> b >> c;  // Ввод с клавиатуры значений переменных a, b, c

   if (a > 0)  // Если значение переменной a > 0

   {

       amount += a;  // К значению переменной amount прибавляем значение переменной a

   }

   if (b > 0)  // Если значение переменной b > 0

   {

       amount += b;  // К значению переменной amount прибавляем значение переменной b

   }

   if (c > 0)  // Если значение переменной b > 0

   {

       amount += c;  // К значению переменной amount прибавляем значение переменной c

   }

   cout << amount;  // Вывод значения переменной amount

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?