В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
roman5555554
roman5555554
04.11.2020 18:05 •  Информатика

написать программу на С++. Пользователь вводит число а. Нужно, чтобы программа определила положительно ли число, если да, то: 1) посчитать сколько разрядов в этом числе;

2) определить каких разрядов больше: со значением от 0 до 4 или от 5 до 9.

Ответ:
малинка188
малинка188
28.11.2020 23:08

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

string a;

cin >> a;

if(stoi(a)>=0) {

cout << a.length() << " разрядов";

} else {

cout << "Wrong data";

перефразировать вторую часть задания, исправлю. Какое значение?

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?