В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danchik56
danchik56
12.09.2022 09:06 •  Информатика

Даны два целых числа. составить программу, которая вычисляет сумму данных чисел.
2) Даны два целых числа. Составить программу, которая вычисляет + - * / данных чисел.
3) Даны стороны прямоугольника а и b, найти площадь и периметр прямоугольника.

Ответ:
Theknopa444
Theknopa444
12.02.2021 15:02

1)

program summa;

var

 first_number, second_number, sum: integer;

begin

 sum := 0;

 readln(first_number, second_number);

 sum := first_number + second_number;

 write(sum);

end.

2)

program arifmetica;

var

 first_number, second_number, sum, dif, multiplic: integer;

 divis: real;

begin

 sum := 0;

 dif := 0;

 multiplic := 0;

 divis := 0;

 readln(first_number, second_number);

 sum := first_number + second_number;

 dif := first_number - second_number;

 multiplic := first_number * second_number;

 divis := first_number / second_number;

 writeln('Сумма: ', sum, ' Разница', dif, ' Умножение: ', multiplic, ' Деление: ', divis);

end.

3)

program rectangle;

var

 a, b, area, perimeter: integer;

begin

 area := 0;

 perimeter := 0;

 readln(a, b);

 area := a * b ;

 perimeter := (a + b) * 2;

 writeln('Периметр: ', perimeter, ' Площадь: ', area);

end.

Объяснение:

1)

program summa;  // Название программы

var

 first_number, second_number, sum: integer;  // Целочисленные переменные для хранения первой, второй чисел и суммы соответственно

begin  // Начало программы

 sum := 0;  // Переменная, хранящая сумму = 0

 readln(first_number, second_number);  // Считываем с клавиатуры первое и второе числа

 sum := first_number + second_number;  // Сумма = первое число + второе число

 write(sum);  // Выводим значение переменной sum

end. // Конец программы

2)

program arifmetica;  // Название программы

var

 first_number, second_number, sum, dif, multiplic: integer;  // Целочисленные переменные для хранения первой, второй чисел, результатов суммы, разности, умножения соответственно

 divis: real;  // Вещественная переменная для хранения результата деления

begin  // Начало программы

 sum := 0;  // Переменная, хранящая сумму = 0

 dif := 0;  // Переменная, хранящая разность = 0

 multiplic := 0;  // Переменная, хранящая умножение = 0

 divis := 0;  // Переменная, хранящая деление = 0

 readln(first_number, second_number);  // Считываем с клавиатуры первое и второе числа

 sum := first_number + second_number;  // Сумма = первое число + второе число

 dif := first_number - second_number;  // Разность = первое число - второе число

 multiplic := first_number * second_number;  // Умножение = первое число * второе число

 divis := first_number / second_number;  // Деление = первое число ÷ второе число

 writeln('Сумма: ', sum, ' Разница', dif, ' Умножение: ', multiplic, ' Деление: ', divis);  // Выводим значения переменных sum, dif, multiplic, divis.

end. // Конец программы

3)

program rectangle;  // Название программы

var

 a, b, area, perimeter: integer;  // Целочисленные переменные для хранения первой, второй чисел, результатов площади и периметра соответственно

begin  // Начало программы

 area := 0;  // Переменная, хранящая площадь = 0

 perimeter := 0;  // Переменная, хранящая периметр = 0

 readln(a, b);  // Считываем с клавиатуры первое и второе числа

 area := a * b ;  // Площадь = a умножить на b

 perimeter := (a + b) * 2;  // Периметр = (a + b), умноженное на 2

 writeln('Периметр: ', perimeter, ' Площадь: ', area);  // Выводим значения переменных perimeter, area.

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?