В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vmartynova77
vmartynova77
01.01.2022 21:21 •  Информатика

информатика

составьте программу для нахождения произведения 10 элементов массива (случайные числа от 0 до 10)​

Ответ:
Wensansys
Wensansys
27.11.2020 23:52

var

 a : array[1..10] of integer;

 i, p : integer;

begin

 p := 1;

 for i := 1 to 10 do

 begin

   a[i] := round(random(11));

   Write(a[i], ', ');

   p := p * a[i];

 end;

 WriteLn();

 WriteLn('Произведение равно ', p);

end.

Объяснение:

0,0(0 оценок)
Ответ:
AliceStilinski
AliceStilinski
27.11.2020 23:52

const n=10;

var a:array[1..n] of integer;

i:integer; p:real;

begin

for i:=1 to n do read(a[i]);

p:=1;

for i:=1 to n do p:=p*a[i];

writeln('p = ',p);

end.

Пример:

4 6 2 3 8 1 4 7 9 1

p = 290304

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?