В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DMN1111
DMN1111
20.03.2022 22:37 •  Информатика

Питон! Дан фрагмент текста, Запрашиваемый у пользователя. Написать программу, находящую наибольшее количество цифр, идущих в нём подряд.

Ответ:
anastasia018710
anastasia018710
26.11.2020 20:50

#!/usr/bin/env python3

import sys

 

text = sys.argv[1]

maxSequenceStart = -1

maxSequenceLength = 0

currentSequenceStart = -1

currentSequenceLength = 0

insideSequence = False

 

for pos, ch in enumerate(text):

   if ch.isdigit():

       if not insideSequence:

           currentSequenceStart = pos

           currentSequenceLength = 1

           insideSequence = True

       else:

           currentSequenceLength += 1

   else:

       if insideSequence:

           insideSequence = False

           if currentSequenceLength > maxSequenceLength:

               maxSequenceStart = currentSequenceStart

               maxSequenceLength = currentSequenceLength

if insideSequence and currentSequenceLength > maxSequenceLength:

   maxSequenceStart = currentSequenceStart

   maxSequenceLength = currentSequenceLength

 

if maxSequenceStart < 0:

   print("No digits in this text!")

else:

   print("Longest digits sequence starts from index", maxSequenceStart,

         "and has length of", maxSequenceLength, "digits")

$ ./max_digits_sequence.py "123 12 1234"

Longest digits sequence starts from index 7 and has length of 4 digits

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?