В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
musalimovvlad
musalimovvlad
19.03.2022 13:24 •  Информатика

Написать программу( желательно си++). Дана непустая последовательность литер, оканчивающаяся точкой.Определить, удовлетворяет ли она следующему свойству: последовательность совпадает с каким-то отрезком ряда 0123456789

Ответ:
krasnikovanastoyhpaj
krasnikovanastoyhpaj
26.11.2020 11:05

#include <iostream>

using namespace std;

int main() {

string s;

string ss("0123456789");

getline(cin, s);

if(s[s.length()-1!='.']) {

 s+=".";

}

string temp;

for(int i = 0; i<ss.length(); ++i) {

 temp+=ss[i];

 if(s.find(temp)!=-1) {

  cout << "yes";

 return 0;

 }

}

cout << "no";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?