В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Щощо
Щощо
22.04.2021 20:26 •  Информатика

Написать программу которая вычисляет сумму положительных из n введенных с клавиатуры целых чисел (for) в паскале abc

Ответ:
KimSuho01
KimSuho01
11.06.2020 03:29

program z1; (Начало программы)

var n, s, i, c:integer; (Раздел описания переменных, n(кол-во чисел), s(сумма чисел), i(счетчик), с(число, введенное с клавиатуры))

begin (тело программы)

writeln ('Кол-во чисел?'); (подсказка для пользавателя)

readln (n); (считывание переменной)

s:=0; (обнуляем переменную)

For i:= 1 to n do begin (цикл будет повторяться от 1 до N; т.к в цикле будет несколько действий открываем операторные скобки (begin\end), начало цикла)

writeln ('Введите число'); (подсказка для пользавателя)

readln(c); (считывание переменной)

If c>0 then s:=s+c; (если с>0 тогда к сумме мы прибавляем число) 

end; (конец цикла)

writeln ('Сумма=',s); (подсказка для пользавателя и ответ)

readln(s); (считывание переменной)

readln; (считывание)

end.(конец программы)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?