В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tim2424
tim2424
22.04.2021 20:26 •  Информатика

Написать программу, , . вид экрана: введите числа. для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67

Ответ:
пппп103
пппп103
11.06.2020 03:29

 

 

 

В задании не сказанно что числа целые  поэтому тип c: real;

 

 Program SumAndAvg;  

 Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat

read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;

until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?