В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
weazelhubozcy1c
weazelhubozcy1c
08.01.2020 10:03 •  Информатика

только программу C++ В григорианском календаре года нумеруются числами 1, 2, 3 и т.д. - это года “нашей эры”.
Предшествующие года называются “первый год до нашей эры”, “второй год до нашей эры” и т.д. Будем
обозначать года нашей эры положительными числами, а года до нашей эры — отрицательными. При
этом года с номером 0 не существует, то есть нумерация лет выглядит так: ..., −3, −2, −1, 1, 2, 3, ... В
летописях написано, что какое-то событие произошло в году номер A, а другое событие произошло
спустя n лет после первого события (или за n лет до первого события). Определите, в каком году
произошло второе событие.
Формат входных данных
Первая строка входных данных содержит число A — год, в котором произошло первое событие. Вторая
строка содержит число n. Если n > 0, то второе событие произошло через n лет после первого события,
а если n < 0, то второе событие произошло за |n| лет до первого события. Оба числа могут быть как
положительными, так и отрицательными.
Формат выходных данных
Программа должна вывести одно целое число — номер года, в который произошло второе событие.

Ответ:
annafilimonova1
annafilimonova1
23.11.2020 09:12

#include <iostream>

using namespace std;

int main(){

 

long long int A;

std::cin >> A;

long long int n;

std::cin >> n;

long long int Answer = A + n;

 

if(A >= 0 && Answer <= 0 || A <= 0 && Answer >= 0){

 if(A >= 0 && Answer <= 0){

  Answer--;

 }else{

  Answer++;

 }

}

 

std::cout << Answer;

 

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?