В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
azzitop
azzitop
27.01.2021 18:55 •  Информатика

Решите какое-либо 1.напишите программу,которая в последовательности целых чисел определяет количество четных отрицаетльных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно,последовательность чисел заканчивается числом 0(0- признак окончания ввода,не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество четных отрицательных чисел. входные данные -1 7 2 -6 0 выходные данные 1 2 напишите программу,которая в последовательности целых чисел определяет количество нечетных положительных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно,последовательность чисел заканчивается числом 0(0- признак окончания ввода,не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество нечетных положительных чисел: -1 7 2 -6 0 выходные данные 1

Ответ:
dinka1820
dinka1820
11.06.2020 02:49

1)

Program pr;
uses crt;
Var a,k,k1:integer;

Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a<>0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.

 

2)
Program pr;
uses crt;
Var a,k,k1:integer;

Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a<>0) and (k1<1000) do
Begin
if (a>0) and (a mod 2<>0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?