В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yuliabler
yuliabler
07.10.2020 06:57 •  Информатика

1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..while, с проверкой вводимого значения на ноль и на отрицательное значение. 2. Сделать описание программы.
3. Отчет оформить в документе WORD.
Факториа́л — функция, определённая на множестве неотрицательных целых чисел. Название происходит от лат. factorialis — действующий, производящий, умножающий; обозначается n!
Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно:
n!=1*2*3*4* ….*n

Ответ:
526424244241242
526424244241242
21.11.2020 17:53

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

   int x, faktorial;

   faktorial = 1;

   cout << "vvedite x" << endl;

   cin >> x;

   if(x <= 0)

   {

       cout << "x dolgen bit' > 0" << endl;

       return 0;

   }

   cout << "faktorial " << x " = "; //выводим заготовку для результата, так как x будет меняться  

   do

   {

       faktorial *= x; //faktorial = faktorial * x;

   }

   //если в условие цикла подставить число, то 0 преобразуется к "ложь", а ненулевое значение к "истина"

   while(--x);//уменьшаем x на 1, затем проверяем его на 0

   cout << faktorial << endl;

   return 0;

}

Объяснение:


1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..whi
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?